nGrinder에서 Groovy script 사용시 java.lang.UnsupportedOperationException 발생

nGrinder에서 Groovy Maven Project를 만들어 사용할 때, 특히 IntelliJ를 사용하려면 Import Groovy Maven Project in IntelliJ를 참조하면 된다.

잘 될 것 같았는데 Unit test에서 시작부터 아래와 같은 에러가 발생했다.

한참을 검색해본 결과 Eclipse의 경우 build 설정시 Groovy 라이브러리를 지우는 과정이 있다는 것을 알게 되었다.
혹시나 IntelliJ에서도 같은 문제일까 해서 Groovy libraries를 모두 지웠더니(File > Project Structure) 아무 문제 없이 잘 작동하기 시작했다.

Groovy를 사용하면 종종 예상치 못한 일을 만나게 된다고 하는데 – 예를 들어 “Using Groovy? Prepare for the unexpected!” – 이런 일을 겪을 때면 아무래도 이 언어의 ‘한계’ 같은 것이 느껴진다.